Welcome to USTVnow Support Customer Service!

OpenSSL "Heartbleed" Vulnerability Update Information was released yesterday about a new vulnerability (CVE-2014-0160) related to OpenSSL, a cryptography library that is used for encrypting a large majority of the traffic across the Internet. An audit of our systems revealed that we were using an affected version of OpenSSL. We immediately took steps to remedy the situation. As of 10:20pm ET on Tuesday April 8th all USTVnow servers have been updated to the latest version of OpenSSL that includes a patch for the vulnerability. No service downtime was incurred during the update. We recommend taking the precautionary step of changing your USTVnow account password. We are monitoring the situation closely and will post updates here and on our facebook page. If you have any questions about this incident, please feel free to open a support ticket.

"Stay up to date with announcements from USTVnow and get answers from our team.

For additional help, click on the "Submit a request" link above to ask us anything that you think we can help you with. Alternatively you may call us Mon-Friday 9-5 MST at +1 (917) 746-8788.

Please first see if your question is answered in the below FAQ.